Modify

Opened 10 years ago

Closed 8 years ago

#1439 closed Bug (Wont Fix)

Icons included in script use wrong size

Reported by: P5ych0Gigabyte Owned by: Jon
Milestone: Component: AutoIt
Version: 3.3.4.0 Severity: None
Keywords: Cc:

Description (last modified by Jpm)

I have a script which uses a button with a 48x48 icon. When using an external ico file it works fine. However when using AutoIt3Wrapper to add an icon to the script it shows as 32x32. It is not a bug in AutoIt3Wrapper as opening the exe is reshacker shows the icon is indeed 48x48.

Attachments (1)

IconBug.zip (2.5 KB) - added by anonymous 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by anonymous

comment:1 Changed 10 years ago by P5ych0Gigabyte

Please remove the link as I have added the file as an attachement.

comment:2 Changed 10 years ago by Jpm

  • Description modified (diff)

comment:3 Changed 10 years ago by VittGam <vittgam@…>

The same bug is with GUICtrlCreateIcon, because if I set width and height to 48 px like this:

GUICtrlCreateIcon(@AutoItExe,0,0,0,48,48)

the image is pixeled from the 32px version. I have to use this:

GUICtrlCreateIcon(@AutoItExe,99,0,0,48,48)

assuming that the icon is named 99 in the resource hacker to have the right size.

comment:4 Changed 9 years ago by Jpm

in fact icons can only be 16x16 or 32x32 as the Windows extraction API we are using only return those formats.
We don't want to reimplement the Windows API, so I will document this restiction.
If we use the same algorithm as for GUICtrlCreateIcon the Icon is not center in the button area. At least that what we found when we implement GuiCtrlSetImage for button

comment:5 Changed 9 years ago by Jpm

  • Owner set to Jon
  • Status changed from new to assigned

comment:6 Changed 8 years ago by Jon

  • Resolution set to Wont Fix
  • Status changed from assigned to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.