Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1447 closed Bug (No Bug)

AutoIt timesout on winwait when run by Microsoft Deployment Toolkit 2008

Reported by: disaak Owned by:
Milestone: Component: AutoIt
Version: 3.3.4.0 Severity: None
Keywords: Cc:

Description

I have a couple AutoIt software installation scripts that timeout when run by a Microsoft Deployment Toolkit task sequence.

The command that fails is WinWait($title, $text, $timeout)
It will timeout even though the window it is waiting for exists.

WinGetTitle("[ACTIVE]", "") returns the title of the window
WinGetText("[ACTIVE]", "") returns the text of the window

If I take the first window out of the main script and add it to the AdlibRegister("unexpected") function, the window is found and dealt with but then the script times out while waiting for the next window.

If I run the script manually while the Microsoft Deployment Toolkit is running, it also times out.
If I run the script manually when the toolkit isn't running it runs like it is supposed to.
Sometimes I can kickstart the script by jiggling the mouse.
I tried using an AutoIt script that jiggles the mouse; it didn't help.

The deployment toolkit runs TsProgressUI.exe which displays a progress bar on top of all other windows. This may be what is causing a conflict with AutoIt.

I tried to find another bug report on this but didn't. I did find one other user with what sounds the same problem in the forums but the was no answer; probably because he didn't give very much info. http://www.autoitscript.com/forum/index.php?showtopic=97308&st=0&p=699510&hl=mdt&fromsearch=1&#entry699510

Attachments (1)

Bad.au3 (4.6 KB) - added by disaak 10 years ago.
AutoIt script

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by disaak

AutoIt script

comment:1 follow-up: Changed 10 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Sigh. What is it about that big red box that people are ignoring? You haven't clearly defined a bug, you haven't provided a short script that demonstrates the problem and it sure sounds to me like you need support.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 10 years ago by disaak

Replying to Valik:

Sigh. What is it about that big red box that people are ignoring? You haven't clearly defined a bug, you haven't provided a short script that demonstrates the problem and it sure sounds to me like you need support.

SIGH. I don't know what else I could do to more clearly define the bug. I supplied a script. I said that the script only fails when run by the deployment toolkit in a task sequence and that it probably has to do with a conflict with the TsProgressUI.exe command used by the Microsoft Deployment Toolkit. What else do you need? All you need to do is ask. And yes I did read the guidelines.

If you don't have time or don't think this bug is worth your effort then tell me that, don't just tell me it sounds like a support problem.

Thank you

comment:3 in reply to: ↑ 2 Changed 10 years ago by Valik

Replying to disaak:

And yes I did read the guidelines.

Alright, let me re-phrase my question. What does it take to get you to apply the guidelines? That script contains so much useless stuff I don't know where to begin. From the description of your problem you need about 2 lines of code to reproduce it:

Run("notepad.exe")
WinWait("Untitled")

With the caveat that the program you suspect of interfering must also be running. It doesn't take a 150 line script.

If you don't have time or don't think this bug is worth your effort then tell me that, don't just tell me it sounds like a support problem.

I don't think it's a bug. I don't wish to spend the effort to prove it's not. If it is a bug I'm more than willing to fix it but you haven't given any indication that it is a bug. What I glean is that the program is interfering in some unexpected fashion and you haven't found the correct way to play nicely with the program. That doesn't mean AutoIt has bugs.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.