Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1461 closed Bug (No Bug)

RightTab and LeftTab under ControlComand not working for Class:_wx_SysTabCtl32

Reported by: coolnetalias Owned by:
Milestone: Component: AutoIt
Version: 3.3.4.0 Severity: None
Keywords: CommandControl, TabRight, TabLeft Cc:

Description

I am making a POC using the FileZilla ftp client. The navigation steps of the control are as follows:

  1. Open FileZilla.
  2. Press Ctrl + s.
  3. Site manager window will be launched. Here there are 4 tabs; General, Advanced, Transfer settings and Chatset.
  4. When I use the code
    ControlCommand ("Site Manager","","SysTabControl321","TabRight","")
    

The next tab i.e. Advanced does not get opened rather General remains as it is.

Attachments (0)

Change History (4)

comment:1 in reply to: ↑ description Changed 10 years ago by anonymous

Replying to coolnetalias:

I am making a POC using the FileZilla ftp client. The navigation steps of the control are as follows:

  1. Open FileZilla.
  2. Press Ctrl + s.
  3. Site manager window will be launched. Here there are 4 tabs; General, Advanced, Transfer settings and Chatset.
  4. When I use the code
    ControlCommand ("Site Manager","","SysTabControl321","TabRight","")
    

The next tab i.e. Advanced does not get opened rather General remains as it is.

If you need more information please do me a favour and drop an email @ coolnetalias@….

comment:2 Changed 10 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Err, you're not using the right class name. Did you actually look at the Site Manager window with Au3Info to get the right information? Once I corrected the wrong class the code works just fine.

No AutoIt bug here. You should probably use the forum in the future since this was a basic support question, not a bug.

comment:3 follow-up: Changed 10 years ago by coolnetalias

Hi Valik,

Thanks for the quick reply. I used Au3Info to for getting the class name. I am using filezilla 3.3.1 for the testing purposes. Which version are you using also, I would appreciate if you can put the corrected code here.

Thanks you so much for reply,
coolnetalias.

comment:4 in reply to: ↑ 3 Changed 10 years ago by anonymous

Sorry for all the trouble is caused, it worked correctly with the following code.

ControlCommand ("Site Manager","","_wx_SysTabCtl321","TabRight","")

Replying to coolnetalias:

Hi Valik,

Thanks for the quick reply. I used Au3Info to for getting the class name. I am using filezilla 3.3.1 for the testing purposes. Which version are you using also, I would appreciate if you can put the corrected code here.

Thanks you so much for reply,
coolnetalias.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.