Modify

Opened 10 years ago

Closed 10 years ago

#1473 closed Bug (Completed)

Debug.au3, _DebugReportVar(), Line format, Scite support?

Reported by: anonymous Owned by: Jon
Milestone: 3.3.5.5 Component: Standard UDFs
Version: 3.3.5.4 Severity: None
Keywords: Debug.au3 _DebugReportVar Cc:

Description

Debug.au3
Line 286

Local $sData = "@@ Debug(" & $ScriptLineNumber & "): " & __Debug_DataType($vVar) & " -> " & $varName

Think that should be ... To make the printed line in scite a active code link. (added space at ") : ")

Local $sData = "@@ Debug(" & $ScriptLineNumber & ") : " & __Debug_DataType($vVar) & " -> " & $varName

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by Jon

Anyone see a problem with making the change suggested? I'm not familiar with the function myself.

comment:2 Changed 10 years ago by Jpm

In fact there is not a really bug. Just the reporter want to use the info in the edit control inside Scite so an extra blank help

comment:3 Changed 10 years ago by anonymous

not really a bug

The line formatting suggests it was intended to make use of scite code-linkback feature in the output pane in my mind.
If thats the case, it somewhat classifies as a bug to me. (Trivial, but unintentional behavior none the less)
If is was the result of two coders, one(UDF creator) copying the format from a other(Scite minded) source, than the bug part it a open issue and can it be considered more a request I guess.

comment:4 Changed 10 years ago by Jon

  • Milestone set to 3.3.5.5
  • Owner changed from Gary to Jon
  • Resolution set to Completed
  • Status changed from new to closed

Added by revision [5716] in version: 3.3.5.5

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.