Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1477 closed Bug (Wont Fix)

Iterpretator doesn't recognize wrong(?) syntax (in operators)

Reported by: MrCreatoR <mscreator@…> Owned by:
Milestone: Component: AutoIt
Version: 3.3.4.0 Severity: None
Keywords: Cc:

Description

This little script will reproduce the bug:

$iRet = Number(1 Not = 0)
ConsoleWrite($iRet)

just run it, it will output 1, althought i am not sure if it's a bug in the interpretator or in the syntax checker, since the last one shows a syntax error.

AutoIt:3.3.4.0 (Os:WIN_XP/X86/Service Pack 2 Language:0419 Keyboard:00000409 Cpu:X86)

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by Jon

  • Resolution set to Wont Fix
  • Status changed from new to closed

It's due to our simplistic expression parsing. Won't be fixed unless we rewrite the entire thing in future.

comment:2 Changed 10 years ago by MrCreatoR <mscreator@…>

So it's syntax error? or it's ok to use these kind of statements?

comment:3 Changed 10 years ago by Valik

Who in their right mind would use a statement like that?

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.