Modify

Opened 9 years ago

Closed 8 years ago

#1492 closed Bug (No Bug)

Problem with listview AND $WS_EX_COMPOSITED in a gui

Reported by: funkey Owned by: Jon
Milestone: Component: AutoIt
Version: 3.3.4.0 Severity: None
Keywords: Cc:

Description (last modified by Valik)

I have high CPU load and there is no listview visible.

;Problem with listview AND $WS_EX_COMPOSITED in a gui

$Form1 = GUICreate("Bug-Test", 200, 200, -1, -1, -1, BitOR(0x02000000, 0x00000010)); $WS_EX_COMPOSITED, WS_EX_ACCEPTFILES))
$hLV = GUICtrlCreateListView("", 10, 10, 180, 180)

GUISetState(@SW_SHOW)

While 1
    $nMsg = GUIGetMsg()
    Switch $nMsg
        Case -3
            Exit
    EndSwitch
WEnd

AutoIt:3.3.4.0 (Os:WIN_XP/X86/Service Pack 2 Language:0407 Keyboard:00000407 Cpu:X64)

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by Jpm

I don't know why you need to use such extended style but MSDN doc say

WS_EX_COMPOSITED

Paints all descendants of a window in bottom-to-top painting order using double-buffering. For more information, see Remarks. This cannot be used if the window has a class style of either CS_OWNDC or CS_CLASSDC. 


That exactly what Autoit is using for GuiCreate. I plan to reject this extended style. I think everybody will agree ...

comment:2 Changed 9 years ago by anonymous

And how to reduce flickering while resizing? $WS_EX_COMPOSITED works great for that.

comment:3 Changed 9 years ago by Jpm

I am afraid to suppress th CS_OWNDC that currently AutoIt is setting when creating a GUI.
Valik mention that the AutoIt must be subclass when using such extended style to have your own behavior.

comment:4 Changed 9 years ago by Jpm

I just read http://www.codeguru.com/forum/showthread.php?t=324061
and as I understand it can be hard to manage ...

comment:5 Changed 9 years ago by Jpm

I am not able to fix such behavior the suppression of CS_OWNDC as I try to do it does not help either.
I leave to other Dev the final answer on this ticket

comment:6 Changed 9 years ago by Jpm

  • Owner set to Jon
  • Status changed from new to assigned

comment:7 Changed 8 years ago by Valik

  • Description modified (diff)
  • Resolution set to No Bug
  • Status changed from assigned to closed

This is not a bug. The documentation for WS_EX_COMPOSITED says it is not compatible with the CS_OWNDC or CS_CLASSDC class styles. Closing as no bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.