Modify

Opened 9 years ago

Closed 9 years ago

#1518 closed Bug (Fixed)

DropDown-Menu of ComboBoxes are not available on x64-Exe

Reported by: skyteddy Owned by:
Milestone: Future Release Component: AutoIt
Version: 3.3.6.0 Severity: None
Keywords: Cc:

Description

Hello,

in my big script, with more then 10.000 lines of code, I have a lot of ComboBoxes.

The script works pretty good if I run it in the SciTe F5-Kay). It works correctly too, if I use the x86-compiler but the menu of the ComboBoxes will not displayed in a x64-exe.

The same script works with the x64-Compiler of Version 3.3.5.6.

I cannot isolate the code to reproduce it in a small program, but if I take a look in the exe-File, I can't find any manifest for the comboboxes! ProgAndy confirms this in the German forum.

the comboboxes works in a x64-exe if I set the value "height" for each combobox. See attachment.

I hope this helps.

Many thanks in advance
R@iner

#Region ;**** Directives created by AutoIt3Wrapper_GUI ****
#AutoIt3Wrapper_UseX64=y
#EndRegion ;**** Directives created by AutoIt3Wrapper_GUI ****
#include <GUIConstantsEx.au3>
#include <String.au3>

Opt('MustDeclareVars', 1)

Example()
Exit

Func Example()
    Local $msg
    Local $MyGui = GUICreate("Combo-Test", 290, 620) ; will create a dialog box that when displayed is centered

    Local $LastX = 10, $LastY = 15, $width = 170, $height = -10

    GUICtrlCreateCombo("item1", $LastX, $LastY, $width) ; no height
    GUICtrlSetData(-1, "item2|item3|item4|item5", "item3") ; add other item snd set a new default
    GUICtrlCreateLabel("no height", $LastX + $width + 20, $LastY, 50)

    For $x = 1 To 14
        $LastY += 40
        $height += 10
        GUICtrlCreateCombo("item1", $LastX, $LastY, $width, $height)
        GUICtrlSetData(-1, "item2|item3|item4|item5", "item3") ; add other item snd set a new default
        GUICtrlCreateLabel("height "& $height, $LastX + $width + 20, $LastY, 50)
    Next

    GUISetState()

    ; Run the GUI until the dialog is closed
    While 1
        $msg = GUIGetMsg()

        If $msg = $GUI_EVENT_CLOSE Then ExitLoop
    WEnd

    GUISetState(@SW_HIDE)
    GUIDelete($MyGui)
EndFunc   ;==>Example

Attachments (0)

Change History (1)

comment:1 Changed 9 years ago by Valik

  • Milestone set to Future Release
  • Resolution set to Fixed
  • Status changed from new to closed

We know. The manifest is missing from x64 compiled scripts because Visual Studio is retarded and likes to do this to us. It will be fixed next release.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.