Modify

Opened 10 years ago

Closed 8 years ago

#1523 closed Feature Request (Duplicate)

Au3Check support UNICODE and all Include file use unicode enc.

Reported by: thesnoW Owned by: Jos
Milestone: Component: Au3Check
Version: Severity: None
Keywords: Cc:

Description

1.Au3Check support UNICODE script file.

2.All Include file use unicode encode is better.
like:

If Chr(0x97)="?" Then MsgBox(32,"",'0x97 = ?')

In non-english system,will popup a msgbox.

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by thesnoW

sorry,it's a Feature Request.

comment:2 Changed 10 years ago by Valik

  • Type changed from Bug to Feature Request
  • Version 3.3.6.0 deleted

I agree that Au3Check needs to support non-ANSI file formats. Right now it silently returns success which is very confusing. However, I do not agree we should change the encoding of the UDF library.

comment:3 Changed 10 years ago by Valik

  • Component changed from AutoIt to Au3Check
  • Owner set to Jos

comment:4 Changed 10 years ago by thesnoW

can replace all of 0x97 char in UDF library (and help script file)?
exp:
\Include\GuiEdit.au3
line 862
---
in English
; _GUICtrlEdit_SetRECT set—it will be approximately correct, but it can be off by a few pixels.

in Chinese
; _GUICtrlEdit_SetRECT set¡ªit will be approximately correct, but it can be off by a few pixels.
---

comment:5 Changed 8 years ago by trancexx

See bug report #2091.

comment:6 Changed 8 years ago by Valik

  • Resolution set to Duplicate
  • Status changed from new to closed

Closing as a duplicate of #2091.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jos.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.