Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#154 closed Bug (No Bug)

Error : Can not redeclare a constant

Reported by: eyjerome@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.10.0 Severity:
Keywords: Cc:

Description

Hello !

I'm a new user of AutoIt (3.2.10.0). For start, i used the help file. But, when i use the sample script of the function _ArrayAdd (or other) :

#include <Array.au3>
Dim $avArray[10]
$avArray[0] = "JPM"
$avArray[1] = "Holger"
$avArray[2] = "Jon"
$avArray[3] = "Larry"
$avArray[4] = "Jeremy"
$avArray[5] = "Valik"
$avArray[6] = "Cyberslug"
$avArray[7] = "Nutster"
$avArray[8] = "JdeB"
$avArray[9] = "Tylo"
_ArrayDisplay( $avArray, "Whole array" )
_ArrayAdd( $avArray,"Brian")
_ArrayDisplay( $avArray, "Updated Array" )

I get :

Files\AutoIt3\Examples\Helpfile\_ArrayAdd.au3"    
C:\PROGRAM FILES\AUTOIT3\Include\Memory.au3 (56) : ==> Can not redeclare a constant.: 
Global Const $PROCESS_TERMINATE = 0x00000001 
Global Const ^ ERROR
>Exit code: 1    Time: 3.380

Can I make an error or is this a bug ?

Thanks (and sorry for my english ;-) )

Jérôme

Attachments (0)

Change History (3)

comment:1 Changed 12 years ago by Jpm

  • Resolution set to No Bug
  • Status changed from new to closed

using your info cannot reproduce the problem. perhaps reinstallation of AutoIt can solve your problem

comment:2 follow-up: Changed 12 years ago by Valik

This is a support question, ask it on the forum, not here.

comment:3 in reply to: ↑ 2 Changed 12 years ago by anonymous

Replying to Valik:

This is a support question, ask it on the forum, not here.

I uninstall and reinstall autoit. The problem persists.

I will try the forum.

Thank you for your response to every two.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.