Modify

Opened 10 years ago

Closed 10 years ago

#1548 closed Bug (No Bug)

Multiple listviews in one GUI behave strangely

Reported by: JonnyThunder Owned by:
Milestone: Component: AutoIt
Version: 3.3.6.0 Severity: None
Keywords: listview, copy Cc:

Description

I'd posted this bug to the forum but didn't get a reply, so assuming it IS a bug of some kind!

On a GUI with two ListViews - if you use Copyitems it only works in one direction. I'm assuming that there is an issue with the ListView control IDs or something similar.

Attached is a simple example of the issue in progress.

Attachments (1)

example.au3 (3.7 KB) - added by JonnyThunder 10 years ago.
example of listview issue. Drag left to right, then right to left!

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by JonnyThunder

example of listview issue. Drag left to right, then right to left!

comment:1 Changed 10 years ago by JonnyThunder

Hello,

Some of the helpful guys on the forum showed me how to get the example working - but we're still unsure if this is a bug or not. You can see the conversation here...

http://www.autoitscript.com/forum/index.php?showtopic=112358

Cheers,

comment:2 Changed 10 years ago by Jpm

The main problem is you mix using standard builtin function as GUI... with the UDF onea which are not creating controlid for listitem.
You must avoid such mix. Some works some does not. I am sure I cannot correct them all.
In your case I can have a solution But I don't like to do it as Other case will fail as I say above.
If you agree I close it as NO BUG

comment:3 Changed 10 years ago by JonnyThunder

Yeah man, go for it. If you're happy it's not a bug.

comment:4 Changed 10 years ago by Jpm

  • Resolution set to No Bug
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.