Modify

Opened 9 years ago

Closed 9 years ago

#1562 closed Bug (No Bug)

multiple conditions fail

Reported by: lex771@… Owned by: Jos
Milestone: Component: SciTE4AutoIt
Version: Other Severity: None
Keywords: Cc:

Description

;The problem can best be descriped by the following code:
$feed = "3"
;The problem happens at Switch... Case...
;when there are multiple conditions:
Switch $feed

Case "1" Or "2"

MsgBox(16, "?", "this also happens when $feed = 3")

Case Else

MsgBox(16, "?", "this never happens")

EndSwitch
;The problem is the same at Select... Case...:
Select

Case $feed = "1" Or "2"

MsgBox(16, "?", "this also happens when $feed = 3")

Case Else

MsgBox(16, "?", "this never happens")

EndSelect
;The problem is the same at If... Then...:
If $feed = "1" Or "2" Then

MsgBox(16, "?", "this also happens when $feed = 3")

Else

MsgBox(16, "?", "this never happens")

EndIf
;The compiler accepts this but der program behaves not as supposed
;Is this a bug?
;I use SciTE4AutoIt3 Version 1.79

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by TicketCleanup

  • Version set to Other

Automatic ticket cleanup.

comment:2 Changed 9 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Taken straight from the guidelines you didn't read:

If you are asking a question you do not have a bug to report, use the forum to ask questions.

The problem, as it were, exists between the keyboard and chair. Learn how the language works - via the forum if necessary - and don't waste time posting silly user-errors as bugs in the language.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jos.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.