Modify

Opened 9 years ago

Closed 9 years ago

#1567 closed Bug (No Bug)

FileExists() returns false in error when x86-compiled script runs on x64 Win 7

Reported by: scriptingsteve Owned by:
Milestone: Component: AutoIt
Version: 3.3.6.0 Severity: None
Keywords: Cc:

Description

I have a 32-bit-compiled autoit script that is returning false in error when run on 64-bit Windows 7 for this code:

{{
$Dir=@WindowsDir & "\System32\Drivers\mrxsmb10.sys"
If FileExists($Dir) Then
Msgbox(64,"File found","File '" & $Dir & "' Version " & FileGetVersion($Dir))
Else
Msgbox(16,"Error","File '" & $Dir & "' not found.")
EndIf
}}

The file is physically in the above location (C:\Windows\System32\Drivers\Mrxsmb10.sys). When the script is compiled x86 (AutoIt 3360), it returns false (incorrect). If the same script is recompiled as x64(AutoIt 3360), it returns true (correct).

Attachments (0)

Change History (1)

comment:1 Changed 9 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

If you post on this issue tracker again you will be permanently blocked from this website. This is the second time you've flagrantly ignored the stated guidelines even after a not-so-gentle push to read the guidelines. This is the second time you've opened a bug report for something that is not a bug. Your code is broken because you don't understand WOW64. That means you need support. Use the forum or get blocked from the site. Your call.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.