Modify

Opened 9 years ago

Closed 9 years ago

#1578 closed Bug (Works For Me)

DirCopy doesn't work unless you specify option 1 - Overwrite

Reported by: Wooltown Owned by:
Milestone: Component: AutoIt
Version: 3.3.6.0 Severity: None
Keywords: Cc:

Description

Running on Windows XP SP3, English version

I have a couple of files in "C:\Backup\Files" and want to copy them into the existing directory "C:\temp" with option "0 - do not overwrite existing files", it doesn't work if the directory exists, but if the directory doesn't exist it works fine.

Is this by design or a bug ?

$err = DirCopy("C:\Backup\Files" , "C:\temp",0)
msgbox(0,"er",$err)

Attachments (0)

Change History (3)

comment:1 follow-up: Changed 9 years ago by Jpm

can you be more explicit does output dir already have those input dir files?
if yes that not a bug

comment:2 in reply to: ↑ 1 ; follow-up: Changed 9 years ago by MrCreatoR <mscreator@…>

Replying to Jpm:

can you be more explicit does output dir already have those input dir files?
if yes that not a bug

I have checked that issue, and indeed there is a bug - the destination folder exists but it's empty, files are not copied from source dir (with flag = 0).

comment:3 in reply to: ↑ 2 Changed 9 years ago by Jpm

  • Resolution set to Works For Me
  • Status changed from new to closed

Replying to MrCreatoR <mscreator@…>:

Replying to Jpm:

can you be more explicit does output dir already have those input dir files?
if yes that not a bug

I have checked that issue, and indeed there is a bug - the destination folder exists but it's empty, files are not copied from source dir (with flag = 0).

I understand your point but overiding is needed to reuse the target stuff.
So any problem in creation lead to an error not just the files copy.
Perhaps doc must be more precise.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.