Modify

Opened 9 years ago

Closed 9 years ago

#1587 closed Bug (Duplicate)

Modified Debug functionality

Reported by: jr@… Owned by: Gary
Milestone: Component: Standard UDFs
Version: 3.3.6.1 Severity: None
Keywords: Cc:

Description

After installing the newest 3.3.6.1 version of AutoIT I found that the functionality for _DebugSetup has been changed significantly. Instead of using the notepad window, it now features a built-in report window plus some other options. Apart from the fact that the report window has no search capabilities, the real problem is that now all scripts that have debugging activated exit only after the report window is closed. This is a real problem in cases where you have multiple processes run in succession (restart). I use the debugging capability for tracing purposes, which will be no longer possible since the processes refuse to exit.

Running the example you can see in the task manager that both processes will stay active until the debug window is closed.

Attachments (0)

Change History (1)

comment:1 Changed 9 years ago by Valik

  • Resolution set to Duplicate
  • Status changed from new to closed

Closing as duplicate of #1588.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Gary.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.