Modify

Opened 12 years ago

Closed 12 years ago

#161 closed Bug (Works For Me)

ControlSend() working buggy on Vista

Reported by: UrzzeR@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.10.0 Severity:
Keywords: Vista bugs Cc:

Description

Well, on Vista only it works buggy.
So, what is the bug:
I want to send a "Auto-it Rox" string to a program via ControlSend()function.
But instead of "Auto-it Rox" I get something like "65uto-it R111x".
What we have come to in our topic discussion: when you use a ControlSend() on Vista you have a big probability to have ASCII codes instead of characters.

When I tested my script on friend's XP computer, it worked perfectly. http://www.autoitscript.com/forum/index.php?showtopic=65859 - the URL to our topic discussion.

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Valik

  • Resolution set to Works For Me
  • Status changed from new to closed

You haven't provided a test script. You haven't really provide any useful details for how to reproduce this. After following the link to your thread, I discover the application you are using is a game which doesn't even have Window controls. I'm inclined to say this is Works For Me until you can give something that can be reproduced which doesn't involve a game.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.