Modify

Opened 9 years ago

Closed 9 years ago

Last modified 12 months ago

#1663 closed Bug (Fixed)

Au3Recorder x64 does not work on x64 machines.

Reported by: anonymous Owned by: Jpm
Milestone: 3.3.7.0 Component: Other
Version: 3.3.6.0 Severity: None
Keywords: Au3Recorder Cc:

Description

Going into AU3Recorder, either using the executive or from SCITE failed with the message "DLL failed to load", on all x64 machines, i.e., Windows 7 and Windows XP x64. I tried this on both real world machines as well as VMWare virtual machines, with and without any anti-virus programs. On Windows XP x86 machines, the function work fine.

Attachments (1)

Au3Record.exe (126.5 KB) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 9 years ago by Jpm

  • Component changed from AutoIt to Other
  • Keywords Au3Recorder added
  • Summary changed from Au3Recoder x64 does not work on x64 machines. to Au3Recorder x64 does not work on x64 machines.

comment:2 Changed 9 years ago by Jpm

  • Owner set to Jon
  • Status changed from new to assigned

In fact the ASWHook.dll has not been ported to X64. The Au3Recorder_X64.exe is delivered by error.
perhaps AU3Wrapper can be modified until an ASWhook.dll be ported to X64.
in short the Au3Record cannot work in X64 mode. Only X86 can run on X64 plateform

comment:3 Changed 9 years ago by Kenny Lau <kenlau22@…>

I am not sure what you mean. You mean that previously, when I invoked the Au3Recorder function in x64 machines, I was basically running an x86 version? That's fine I guess, but how do I do that now on x64 machines?

It does not matter really whether I run x86 or x64 version, as long as it run, but as it stands now, whenever I invoked Au3Recorder from SCITE, the x64 automatically runs and fails, which more or less crippled the software.

An interim measure on how to solve this will be much appreciated.

comment:4 Changed 9 years ago by Jpm

an iterim will be to patch Au3wrapper to use only X86 version but certainly the Au3Recorder will not capture everything.
If you can just run the X86 module under an X64 System.

comment:5 Changed 9 years ago by Jpm

Waiting the ASWhook_x64.dll porting, I remove the Au3Recorder_x64.exe.

comment:6 Changed 9 years ago by Jpm

  • Milestone set to 3.3.7.0
  • Owner changed from Jon to Jpm
  • Resolution set to Fixed
  • Status changed from assigned to closed

Fixed by revision [5870] in version: 3.3.7.0

comment:7 Changed 9 years ago by rmarkables@…

Hi,

I just installed the latest version of AutoIt and SciTE and the DLL issue still exists. I notice the bug is closed, What did you do to fix it?

The 32bit version of Au3Recorder "works" but nothing like it did before in 32bit Windows.

I notice one entry in the log states the problem is fixed in version 3.3.7.0, but this vesion is not available in the downloads section. Where can ths be downloaded?

Thanks
Mark

comment:8 Changed 8 years ago by anonymous

as of 1/30/2011 the AU3Recorder does not work on a x64 machine.. PERIOD! Anyone who can prove otherwise I welcome your comments!

comment:9 Changed 8 years ago by anonymous

still does not work on x64 system

Changed 6 years ago by anonymous

comment:10 Changed 6 years ago by Jpm

@anonymous
What is the purpose of this .exe?
Just post what is your proposal if any to modify the current source of au3Record which is BTW not opensource
THe current version just run in X32 mode Under a system in 64-bit which is not the most but it is doing the job

comment:11 Changed 4 years ago by anonymous2

@anonymous

Thank you GREATLY for posting the Au3Record.exe file. Since the new version of SCITE DO NOT INCLUDE IT, finding this forum posting was the only way to get back this awesome utility for AutoIt.

comment:12 Changed 12 months ago by anonymous

Still not working, ends up with the same or similar .dll error

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jpm.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.