Modify

Opened 10 years ago

Closed 10 years ago

#1675 closed Bug (Duplicate)

Problem with __EventLog_DecodeComputer

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.3.6.1 Severity: None
Keywords: Eventlog Cc:

Description

it worked with the old Eventlog.au3. Now it returns a wrong part of a string. I don't understand the DLLstruct-stuff and how to write it properly, so I have to file a bug report rather than fixing it myself. I'm using WinXP 32bit. Might be an OS-issue. Can't provide infos for other Windows versions I'm afraid.

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by anonymous

The problem here is similar to Ticket #1336 http://www.autoitscript.com/trac/autoit/ticket/1336
An error in the calculating of the correct buffer size, I guess.
See the Example for _EventLogRead(). The return value for Computer
is not the computername but the same value as Source minus the first letter.

comment:2 Changed 10 years ago by Jpm

  • Resolution set to Duplicate
  • Status changed from new to closed

THe problem is the same as #1496

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.