Modify

Opened 12 years ago

Closed 12 years ago

#171 closed Feature Request (Rejected)

consolewrite() documentation addendum

Reported by: flyingboz Owned by:
Milestone: Component: Documentation
Version: Severity:
Keywords: consolewrite console cui Cc:

Description

Assuming the behavior is desired, and not leveraging a bug...
If there are any other cool behaviors possible (moving the cursor up a line, writing from right to left, etc.), it would be nice if they were documented somewhere as well.

Suggest adding this line (or similar) after "...unless the script is compiled as a console application...:

In a compiled console application, prepending @CR to "data" will reset the cursor location to the beginning of the current line.

Sample code demonstrating functionality (by ResNullis)
#Region ; Directives created by AutoIt3Wrapper_GUI
#AutoIt3Wrapper_Change2CUI=y
#EndRegion ; Directives created by AutoIt3Wrapper_GUI
$ClearProgress = 0

$progress = "ùùùùùùùùùù";Chr(249)
$processing = "Processing ["

For $i = 1 To 3

For $iPos = 1 To 10

$DisplayProgress = StringReplace($progress, $iPos, " ", 1)
ConsoleWrite(@CR & $processing & $DisplayProgress & "]")
Sleep(50)

Next
For $iPos = 10 To 1 Step -1

$DisplayProgress = StringReplace($progress, $iPos, " ", 1)
ConsoleWrite(@CR & $processing & $DisplayProgress & "]")
Sleep(50)

Next

Next

$DisplayProgress = $progress

ConsoleWrite(@CR & $processing & $DisplayProgress & "]")
ConsoleWrite(@CRLF & "DONE")

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by TicketCleanup

  • Version 3.2.11.2 deleted

Automatic ticket cleanup.

comment:2 Changed 12 years ago by Valik

  • Resolution set to Rejected
  • Status changed from new to closed

This doesn't appear to be a bug (I can reproduce it with a simple C++ program). However, it is not an AutoIt feature, either. It seems to be a feature/bug/quirk in the command interpreter. I don't feel that we should be documenting the functionality of other programs.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.