Modify

Opened 10 years ago

Closed 9 years ago

#1714 closed Bug (Wont Fix)

controlID is not evaluated completely

Reported by: u.kolender@… Owned by: Jon
Milestone: Component: AutoIt
Version: 3.3.6.0 Severity: None
Keywords: Cc:

Description

When determining a control by class, id and text the text is not considered for identifying the control.

Example:

  1. Open notepad.
  2. Select to replace a string, so that the replacement dialog is open.
  3. The code:
$title = "Ersetzen" ; replace dialog
$cID = "[CLASS:Button;ID:2;TEXT:Nonsense]" ; cancel button with invalid text
MsgBox(0, "Debug", ControlCommand($title, "", $cID, "IsVisible", ""))

--> the button is found and the result is "1".

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by Jpm

  • Owner set to Jon
  • Status changed from new to assigned

comment:2 Changed 10 years ago by Jpm

In fact when ID:xx is defined if the xx match then the searching is successful whatever other properties that may have been defined.
Perhaps Doc should be more clear on this behavior.
I Leave other Dev the final answer on this.

comment:3 Changed 10 years ago by u.kolender@…

Well, there are some applications using the same id numbers for different controls. They differ in control type and/or text, for instance. So, it would be a great benefit to have ALL determined properties evaluated.

comment:4 Changed 9 years ago by Jon

  • Resolution set to Wont Fix
  • Status changed from assigned to closed

By design for the moment.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.