Modify

Opened 9 years ago

Closed 8 years ago

#1789 closed Bug (Duplicate)

_GUICtrlRichEdit_Create blocking syntax error reporting while in SciTE

Reported by: SPiff59 Owned by:
Milestone: Component: AutoIt
Version: 3.3.6.1 Severity: None
Keywords: Cc:

Description (last modified by Jpm)

Executing the following from within SciTE will not generate a syntax error. Instead, the script will hang indefinitely between the first Msgbox() and the second. A compiled version of the script will error out and terminate properly, so the issue occurs only when launching from within SciTE.

#include <GuiRichEdit.au3>
Global $hRichEdit, $Array[2][2]

$GUI = GUICreate("", 200, 200)
$hRichEdit = _GUICtrlRichEdit_Create($GUI, "", 10, 10, 180, 180)
MsgBox(0,"","About to freeze...")
$Array[1] = "X" ; bad reference to 2-dimension array should cause abend
MsgBox(0,"", "I'll never get this far!")

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by Jpm

  • Description modified (diff)

comment:2 Changed 9 years ago by Jpm

In fact the compiled script crash at the end after the error message as the script as the same problem as #1319.

comment:3 Changed 8 years ago by Valik

  • Resolution set to Duplicate
  • Status changed from new to closed

Closing as a duplicate of #1319.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.