Modify

Opened 11 years ago

Closed 11 years ago

#183 closed Bug (Fixed)

Event of radio control fired when the GUI is reactivated

Reported by: MsCreatoR <mscreator@…> Owned by: Jpm
Milestone: 3.2.11.5 Component: AutoIt
Version: 3.2.10.0 Severity:
Keywords: radio event Cc:

Description

For some reason, when we create a radio control, the same event is triggered when the GUI is unactivated and then activated again.

Bug reproduction:

Run the example bellow, then minimize the GUI, and then activate it back. You should see the message box...

#include <GuiConstants.au3>

$hGUI = GUICreate("Test GUI", 360, 220)

$My_Radio = GUICtrlCreateRadio("Radio", 20, 110)

$Cancel_Button = GUICtrlCreateButton("Cancel", 20, 180, 80, 20)

GUISetState(@SW_SHOW, $hGUI)

While 1
	Switch GUIGetMsg()
		Case $GUI_EVENT_CLOSE, $Cancel_Button
			Exit
		Case $My_Radio
			MsgBox(0, "", "Is this normal?")
			
			Exit ;We need to exit because the message will popup every time
	EndSwitch
WEnd

The same with OnEvent mode, and also if we use advanced mode, i.e GUIGetMsg(1).

It seems that this happening only with Raio control, but i am not 100% sure, tested only few basic controls (label, button, etc.).

BTW, the same bug appears in AutoIt v3.2.8.1.

Thanks.

Attachments (0)

Change History (1)

comment:1 Changed 11 years ago by Jpm

  • Milestone set to 3.2.11.5
  • Owner set to Jpm
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed in version: 3.2.11.5

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jpm.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.