Modify

Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#1938 closed Bug (Works For Me)

_IEQuit IE9

Reported by: Jpm Owned by: Gary
Milestone: Component: Standard UDFs
Version: 3.3.6.1 Severity: None
Keywords: Cc:

Description

The following script does work with IE9/Win7
the Html is not closed
Perhaps more UDF does not work with IE9

#include <IE.au3>

Local $oIE = _IECreate()
_IENavigate($oIE, "file://" & @ScriptDir & "\temp.html", 1)
_IEQuit($oIE)

Attachments (1)

temp.html (187 bytes) - added by Jpm 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by Jpm

comment:1 Changed 9 years ago by AdmiralAlkex

Not practical, but I quickly tested and it works if the script run as admin

#RequireAdmin

comment:2 Changed 9 years ago by DaleHohm

JP,

I cannot reproduce this on Win7 32-bit and IE9. The browser opens and closes just as expected without #RequireAdmin

Are others able to preproduce?

Dale

comment:3 Changed 9 years ago by Jon

  • Resolution set to Works For Me
  • Status changed from new to closed

comment:4 Changed 9 years ago by Jpm

At least Jon reproduce the problem

comment:5 Changed 9 years ago by DaleHohm

JP,

I'd suggest you test with VBS and see what your result is:

set oIE = CreateObject("InternetExplorer.Application")
oIE.visible=1
oIE.navigate2("temp.html")
oIE.quit

Dale

comment:6 Changed 6 years ago by Jpm

Finally I found how to have it working disabling the Protected Mode on Internet security zone.

Look a little strange that local file follow the same rule as the Internet ones but why not

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Gary.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.