Modify

Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#1946 closed Bug (Fixed)

_WordCreate Error?

Reported by: Anomalism@… Owned by: Jon
Milestone: 3.3.7.11 Component: AutoIt
Version: 3.3.7.9 Severity: None
Keywords: WordCreate Cc:

Description

But in 3.3.6.1 it can work.

Code:
$oWordApp = _WordCreate(@WorkingDir & "\" & $sFileName)
$oDoc = _WordDocGetCollection ($oWordApp, 0)
_WordDocFindReplace($oDoc, "<NO>", $sXQNo)

Error msg:
--> Word.au3 Error from function _WordDocOpen, $_WordStatus_InvalidObjectType
--> Word.au3 Error from function _WordDocGetCollection, $_WordStatus_InvalidObjectType
--> Word.au3 Error from function _WordDocFindReplace, $_WordStatus_InvalidDataType

Attachments (0)

Change History (10)

comment:1 follow-up: Changed 9 years ago by Jpm

The change occur in 3.3.7.8

comment:2 in reply to: ↑ 1 Changed 9 years ago by Anomalism@…

Replying to Jpm:

The change occur in 3.3.7.8

You are right. It can not work in 3.3.7.8 yet.

comment:3 follow-up: Changed 9 years ago by Jpm

so use 3.3.7.7 (go to archive beta) until final correction being done.

comment:4 in reply to: ↑ 3 Changed 9 years ago by Anomalism@…

Replying to Jpm:

so use 3.3.7.7 (go to archive beta) until final correction being done.

It can not work in 3.3.7.10 yet...

comment:5 Changed 9 years ago by Jpm

I agree the ticket is not fixed. That's the reason I suggest you use 3.3.7.7 as the regression has been introduce in 3.3.7.8

comment:6 Changed 9 years ago by big_daddy

AutoIt is now returning the object names without the preceding underscore. If following lines are changed in Word.au3 it works as expected.

		Case "application"
			If $s_Name = "_Application" Then $objectOK = True
		Case "document"
			If $s_Name = "_Document" Then $objectOK = True
		Case "application"
			If $s_Name = "_Application" Or $s_Name = "Application" Then $objectOK = True
		Case "document"
			If $s_Name = "_Document" Or $s_Name = "Document" Then $objectOK = True

comment:7 Changed 9 years ago by big_daddy

As per discussion with tracexx, backwards compatibility is not required for internal functions within the standard UDF collection.

The code should be changed as follows:

		Case "application"
			If $s_Name = "Application" Then $objectOK = True
		Case "document"
			If $s_Name = "Document" Then $objectOK = True

comment:8 Changed 9 years ago by Jon

  • Milestone set to 3.3.7.11
  • Owner set to Jon
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed by revision [6171] in version: 3.3.7.11

comment:9 Changed 6 years ago by jessica.zhang@…

This information save me a lot.
But it's very hard find out the latest version of word.au3.
I had download the latest version of AutoIt, after install, there is no word.au3 module at all.
I got one from an old version of AutoIt install, and modify it based on this information.
It works on my Win7 now.
Thanks!

comment:10 Changed 6 years ago by jessica.zhang@…

This information save me a lot.
But it's very hard find out the latest version of word.au3.
I had download the latest version of AutoIt, after install, there is no word.au3 module at all.
I got one from an old version of AutoIt install, and modify it based on this information.
It works on my Win7 now.
Thanks!

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.