Modify

Opened 9 years ago

Closed 8 years ago

#1987 closed Bug (Works For Me)

_GUICtrlRichEdit_StreamFromFile crashes AutoIt

Reported by: User: Stilez Owned by:
Milestone: Component: AutoIt
Version: 3.3.6.1 Severity: None
Keywords: Cc:

Description

Attached script was being modified to stream RTF from a file rather than including it from a variable. Surprisingly it causes AutoIt to crash, both interpreted and also compiled to exe. Debug info below.

Problem signature:

Problem Event Name: APPCRASH
Application Name: autoit3_x64.exe
Application Version: 3.3.6.1
Application Timestamp: 4bc81628
Fault Module Name: MSFTEDIT.DLL
Fault Module Version: 5.41.21.2510
Fault Module Timestamp: 4ce7c7ed
Exception Code: c0000005
Exception Offset: 0000000000036c6f
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 2057
Additional Information 1: 4d00
Additional Information 2: 4d003a019b4253e7a1fdbe2175787182
Additional Information 3: 4830
Additional Information 4: 483000df24cb6952324cd813a7eb8420

Removing the marked line and it doesn't crash.

3.3.6.1 on Win 7 x64 under Vmware 7.1.4 (clean install)

Attachments (2)

Help-en.rtf (2.2 KB) - added by Stilez 9 years ago.
RTF file being used at the time (created in Wordpad)
tmp2.au3 (2.6 KB) - added by Stilez 9 years ago.
Test file for rich test dialog showing the crash

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by Stilez

RTF file being used at the time (created in Wordpad)

Changed 9 years ago by Stilez

Test file for rich test dialog showing the crash

comment:1 Changed 9 years ago by anonymous

Also crashes if you modify to stream from a variable:

$a = FileRead("C:\Users\Temp user\Desktop\QL RC 1.02\Help-en.rtf")
_GUICtrlRichEdit_StreamFromVar($gui_textbox, $a)

1st ever crash of AutoIt.

comment:2 Changed 8 years ago by trancexx

  • Resolution set to Works For Me
  • Status changed from new to closed

I can't reproduce this with current AutoIt no matter what I do or on what system I run that script.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.