Modify

Opened 9 years ago

Closed 8 years ago

#1995 closed Bug (Wont Fix)

Different results on x86 and x64

Reported by: UEZ Owned by:
Milestone: Component: AutoIt
Version: 3.3.6.1 Severity: None
Keywords: Cc:

Description

When I run these lines

#AutoIt3Wrapper_UseX64=n
MsgBox(0,"", StringMid(StringFormat("%-20.*s", "AutoIT.de"),1 , 20))

the result is different to this

#AutoIt3Wrapper_UseX64=y
MsgBox(0,"", StringMid(StringFormat("%-20.*s", "AutoIT.de"),1 , 20))

Should the result not the same?

Br,
UEZ

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by Jpm

In fact AutoIt does really support .* precision.
Your example is wrong as an extra parameter defining the precision will be needed before the string to defined the precision

MsgBox(0,"", StringMid(StringFormat("%-20.*s", 10, "AutoIT.de"),1 , 20))

but as I say Autoit will not support this format
So fix must be done to accept or reject such precision definition

comment:2 Changed 8 years ago by trancexx

Nothing needs fixed. This is not a bug.
The user has invalid syntax of a conversion specification therefore triggering undefined behavior.
All we should do is document that bad syntax causes undefined behavior. When that's done this ticked can be closed.

Last edited 8 years ago by trancexx (previous) (diff)

comment:3 Changed 8 years ago by trancexx

  • Resolution set to Wont Fix
  • Status changed from new to closed

Addressed by revision [7088].

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.