Modify

Opened 12 years ago

Closed 12 years ago

#201 closed Bug (Duplicate)

DLLCall: $aRet[4] is invalid in AutoIT 3.2.10.0

Reported by: Rayburn Owned by: Jpm
Milestone: Component: AutoIt
Version: 3.2.10.0 Severity:
Keywords: Cc:

Description

Hi, I'm new here. I've been creating a script with AutoIT that uses COM. My Script includes a call to IEControlGetObjFromHWND. I keep receiving the error "Subscript uses non-Array variable" on line 4091 of IE.au3. I did error checking to ensure that the window handle that I was passing to the IEControlGetObjFromHWND function was valid, and it was. My script kept stopping with the same error on 2 of the 3 PCs that I tried it on (all XP Pro SP2). On one of the PCs, I never got the error, the script ran flawlessly. I checked the versions of AutoIT, and found that the version that was on the two PCs that generated the error was version 3.2.10.0, and the version on the PC where the script ran flawlessly was 3.2.8.1. Trying the latest beta resulted in the same error. I played around with the IEControlGetObjFromHWND function and added error checking right after the call to DLLCall to see if the $aRet variable was valid, and it wasn't. If you need me to post a script, let me know. I hope I've explained it well enough. Thanks.

Attachments (1)

error.au3 (1.5 KB) - added by Rayburn 12 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 follow-up: Changed 12 years ago by Valik

Always always ALWAYS post a script. This report is worthless without a script.

Also, please don't say "latest beta". That is a moving target and what you think is the latest beta may or may not be. Given the exact version number you tested with.

comment:2 in reply to: ↑ 1 Changed 12 years ago by Rayburn

Sorry!!! Like I said, I'm new here so don't expect me to get it right the first time. Those directions you gave belong in the sticky note about posting bug reports in the bug report section of the forum (which I read before posting).

Replying to Valik:

Always always ALWAYS post a script. This report is worthless without a script.

Also, please don't say "latest beta". That is a moving target and what you think is the latest beta may or may not be. Given the exact version number you tested with.

Changed 12 years ago by Rayburn

comment:3 Changed 12 years ago by Jpm

  • Owner set to Jpm
  • Status changed from new to assigned

Not sure you can use as is internal functions of IE.au3.
I leave to DaleHolm the final answer

comment:4 Changed 12 years ago by DaleHohm

This was a known problem in AutoIt 3.2.10.0 caused by a bug in DllCall. This is fixed in AutoIt Beta 3.2.11.x.

I tested the code and confirmed that it worked in beta 3.2.11.x and failed in 3.2.10.0.

Bug fixed in beta. Please close.

DaleHohm

comment:5 Changed 12 years ago by Valik

  • Resolution set to Duplicate
  • Status changed from assigned to closed

Closing as duplicate since it's long fixed, like I suspected.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jpm.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.