Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2044 closed Bug (No Bug)

IE.au3 error Wend

Reported by: autoit@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.7.20 Severity: None
Keywords: Cc:

Description

Hello all,

for this script :

#include <IE.au3>

$identifiant = "xxx"
$motdepasse = "xxx"

$oIE = _IECreate ("http://www.farmerama.com")
_IELoadWait ($oIE)

$oUser =_IEGetObjByName($oIE,"loginForm_default_username")
$oPass =_IEGetObjByName($oIE,"loginForm_default_password")
_IEFormElementSetValue ($oUser, $identifiant)
_IEFormElementSetValue ($oPass, $motdepasse)

$connexion = _IEFormGetObjByName($oIE, "loginForm_default")
_IEFormSubmit($connexion)

Autoit return this error :

"C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /beta /ErrorStdOut /in "C:\Users\WoW\Desktop\Auto It\test\test connexion.au3" /autoit3dir "C:\Program Files (x86)\AutoIt3\beta" /UserParams

+>04:25:18 Starting AutoIt3Wrapper v.2.0.3.0 Environment(Language:040C Keyboard:0000040C OS:WIN_7/Service Pack 1 CPU:X64 OS:X64)

Running AU3Check (1.54.22.0) from:C:\Program Files (x86)\AutoIt3\Beta

+>04:25:18 AU3Check ended.rc:0

Running:(3.3.7.20):C:\Program Files (x86)\AutoIt3\Beta\autoit3_x64.exe "C:\Users\WoW\Desktop\Auto It\test\test connexion.au3"

C:\Program Files (x86)\AutoIt3\Beta\Include\IE.au3 (585) : ==> The requested action with this object has failed.:
WEnd
WEnd ERROR
->04:25:23 AutoIT3.exe ended.rc:1

Exit code: 1 Time: 6.735

Error appear at the end, just after the form was validate.
Sorry for my english, i wish you anderstand me :)
Good works and thanks for your soft

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by trancexx

  • Resolution set to No Bug
  • Status changed from new to closed

Your code misses error handling.

comment:2 Changed 8 years ago by Jpm

not sure why IE.au3 cannot return @error something instead creating a situation where a "Wend" error is detected.
Error handling is just a way to recover a non error checking ?
Perhaps some work for DaleHolm.

comment:3 Changed 8 years ago by Jpm

In fact IE.au3 has a error recovery routine which does not seem to work.
Perhaps this ticket should be reopened

comment:4 follow-up: Changed 8 years ago by DaleHohm

As I told the original poster when he posted in the forum... I tested his code withIE9 on Win 7 and could not reproduce his trouble. I don't believe there is a bug here.

While it is true that IE.au3 employs error handling, most functions attempt to prevent errors rather than trap them (one nofible exception being _IELoadWait that traps). In it's current form, errors like those from the OP can certainly happen when the HTML/document are changing behind the scenes. Trancexx's statement is correct... when this sort of error is possible, the user needs to employ thie own error handler.

With the most recent betas, additional error handling is possible for IE.au3, but it has not been implemented and there is not yet a schedule to complete such.

Dale

comment:5 in reply to: ↑ 4 Changed 8 years ago by Jpm

Replying to DaleHohm:

As I told the original poster when he posted in the forum... I tested his code withIE9 on Win 7 and could not reproduce his trouble. I don't believe there is a bug here.

While it is true that IE.au3 employs error handling, most functions attempt to prevent errors rather than trap them (one nofible exception being _IELoadWait that traps). In it's current form, errors like those from the OP can certainly happen when the HTML/document are changing behind the scenes. Trancexx's statement is correct... when this sort of error is possible, the user needs to employ thie own error handler.

With the most recent betas, additional error handling is possible for IE.au3, but it has not been implemented and there is not yet a schedule to complete such.

Dale

in fact there is a bug in IE.au3 and certainly another in AutoIt for the Wend Error.
I PM new a fix for IE.au3 so you can validate and commit it as I cannot do anything with SVN. I have now less privilegde than MVP ...

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.