Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2047 closed Bug (No Bug)

ProcessExists bad return

Reported by: Jpm Owned by:
Milestone: Component: AutoIt
Version: 3.3.6.1 Severity: None
Keywords: Cc:

Description

$pid = Run(@comspec, "C:\", @SW_SHOWNORMAL, 2)
ConsoleWrite('@@ Debug(' & @ScriptLineNumber & ') : $pid = ' & $pid & @crlf & '>Error code: ' & @error & '    Extended code: 0x' & Hex( @extended) & @crlf) ;### Debug Console
$active="[class:ConsoleWindowClass]"
WinWaitActive($active)
ConsoleWrite('@@ Debug(' & @ScriptLineNumber & ') : ProcessExists($pid) = ' & ProcessExists($pid) & @crlf & '>Error code: ' & @error & '    Extended code: 0x' & Hex( @extended) & @crlf) ;### Debug Console

The ProcessExists() returns 0 which is wrong.
It is OK if the Stdout is not redirected

Same situation with the Beta. I am running X86 Win7 Sp1

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

This is not a bug. The process really doesn't exist. It closes immediately because it does not have a STDIN stream pointing to anything useful. If you want the program to continue to run then you need to provide a STDIN handle.

comment:2 Changed 9 years ago by Jpm

Thanks,
It can be difficult to understand, perhaps some warning in the doc.

Last edited 9 years ago by Jpm (previous) (diff)

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.