Modify

Opened 12 years ago

Closed 12 years ago

#205 closed Bug (No Bug)

[Vista64] PixelGetColor returns color of desktop picture instead of directX window

Reported by: hactar Owned by:
Milestone: Component: AutoIt
Version: 3.2.11.5 Severity:
Keywords: Cc:

Description

When trying to determine the color of a pixel via PixelGetColor in a directX window (eve online to be precise). When one tries to do so in Vista64 (sp1) with aero turned on it always returns 0 when the directX window is active. If one turns off aero then PixelGetColor returns whatever is under that directX window (eg the window below or if nothing is below the desktop background) instead of the directX windows color at that pixel. When running the exact same script with windows xp sp2 the problem does not occur, the correct color is returned.

Steps to reproduce:

1) Download eve online from http://www.eve-online.com/download/ (free download, download the non premium version for a faster download), install it and launch it.
2) Run the following autoit code:

Sleep(3000);
$mypix = "";
for $i = 100 to 120 Step 1

For $j = 118 to 145 Step 1

$mypix = $mypix & $i & "," & $j & ":" & hex(PixelGetColor($i,$j),6) & " ";

Next

Next
MsgBox(0,"color",$mypix);

This will return the colors of a small area. With aero turned on pixelgetcolor will return 0. With aero turned off the color returned will be what ever the color below the eve window is (set your background to white for example to easily see that the color returned is wrong).

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by hactar

Further investigation has revealed that the issue is in fact anti aliasing. If a game uses anti aliasing getpixelcolor no longer "sees" the window. Probably not a bug then, but an update to the documentation would be help that pixelsearch and getpixelcolor both require antialiasing for the app to be turned off.

comment:2 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Closing as No Bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.