Modify

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#2056 closed Bug (Fixed)

Excel.au3 - 5 Broken Functions

Reported by: Aru Owned by:
Milestone: Component: AutoIt
Version: 3.3.7.21 Severity: None
Keywords: Excel Excel.au3 Cc:

Description

3.3.7.21(beta)
3.3.6.1

Any reference to $oExcel.ActiveWorkbook.Sheets.Count after creating the Excel object with _ExcelBookAttach() seems to error. These are the five functions with that reference:

_ExcelBookOpen
_ExcelSheetDelete
_ExcelSheetList
_ExcelSheetActivate
_ExcelSheetMove

And this is the error:

C:\Program Files\AutoIt3\Include\Excel.au3 (1063) : ==> The requested action with this object has failed.:
Local $iTemp = $oExcel.ActiveWorkbook.Sheets.Count
Local $iTemp = $oExcel.ActiveWorkbook^ ERROR

References to $oExcel.ActiveWorkbook.Sheets() work fine. It's the ones without parenthesis that break. They also all work fine if the object is created with _ExcelBookOpen() instead of _ExcelBookAttach().

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by Aru

Windows 7, Excel 2010

comment:2 Changed 7 years ago by anonymous

missing a repro script
Thanks

comment:3 Changed 7 years ago by trancexx

  • Resolution set to Fixed
  • Status changed from new to closed

Even though the issue is not directly addressed, it's fixed in next beta as collateral.

comment:4 Changed 7 years ago by Jpm

not sure it was not a NO BUG as we cannot reproduce without a repro script.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.