Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2064 closed Bug (No Bug)

DriveStatus returns INVALID on existing path (by Volume Name)

Reported by: MrCreatoR <mscreator@…> Owned by:
Milestone: Component: AutoIt
Version: 3.3.7.22 Severity: None
Keywords: DriveStatus INVALID Cc:

Description

Run this on 3.3.7.1 and lower versions:

$sGuid = DllCall('kernel32.dll', 'int', 'GetVolumeNameForVolumeMountPointW', 'wstr', 'C:\', 'wstr', '', 'dword', 80)
$sGuid = $sGuid[2]

$sStatus = DriveStatus($sGuid)
$sType = DriveGetType($sGuid)

MsgBox(262144, 'Status', $sStatus)
MsgBox(262144, 'Type', $sType)

The result is fine, but if we try it on 3.3.7.5 and above (i haven't tested on versions between 3.3.7.1 and 3.3.7.5), we will get INVALID from the DriveStatus.
But as we can see, DriveGetType returns correct value.

Environment(Language:0419 Keyboard:00000409 OS:WIN_7/ CPU:X64 OS:X86)

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by trancexx

  • Resolution set to No Bug
  • Status changed from new to closed

The change is introduced in v3.3.7.2 with revision [5991]. Change log entry is:
Fixed #1860: DriveStatus Returns Ready with blank value.

The description for the function is that it takes path of drive to receive information from as parameter, not a volume GUID path. The fact that something undocumented worked before doesn't make it a bug when no longer does.

Therefore this is not a bug.

comment:2 Changed 8 years ago by Jpm

I think DriveStatus must work as DriveGetType which does not care of the extended syntax

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.