Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2112 closed Bug (Fixed)

Running debugger window and clicking close script window makes this window inresponsive

Reported by: hebrayah@… Owned by: guinness
Milestone: 3.3.9.0 Component: Standard UDFs
Version: 3.3.8.0 Severity: None
Keywords: Cc:

Description

Running GUI created from your "Example GUI" works ok, but if debugger window is runned with :

#include <Debug.au3>
_DebugSetup("Scribe debuger", True)

After clicking the window close button script is getting unresponsive

Attachments (2)

test3.au3 (793 bytes) - added by hebrayah@… 7 years ago.
Script working correctly
test2.au3 (856 bytes) - added by hebrayah@… 7 years ago.
non correct script

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by hebrayah@…

Script working correctly

Changed 7 years ago by hebrayah@…

non correct script

comment:1 Changed 7 years ago by Melba23

It seems that this was first reported and fixed here http://www.autoitscript.com/trac/autoit/ticket/1588 but has now reappeared.

M23

Last edited 7 years ago by AdmiralAlkex (previous) (diff)

comment:2 Changed 7 years ago by Jpm

In fact it is working as intended from my point of view.
When you click close the script is waiting you close the output "report Log" windows to allow you to visualize what occurs instead of closing the "report Log" debug windows.
Perhaps a last message could have been out saying that the script will quit only when the output "report Log" window will be closed.

comment:3 Changed 7 years ago by guinness

  • Milestone set to 3.3.9.0
  • Owner set to guinness
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed by revision [6713] in version: 3.3.9.0

comment:4 Changed 7 years ago by guinness

This ticket is referenced in revision: [6714]

comment:5 Changed 7 years ago by Jpm

  • Component changed from AutoIt to Standard UDFs

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain guinness.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.