Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2118 closed Bug (No Bug)

bug when launching a command Line program using @SW_HIDE

Reported by: Le solutionneur Owned by:
Milestone: Component: AutoIt
Version: 3.3.8.0 Severity: None
Keywords: @SW_HIDE flag run Cc:

Description

Using the command run(a"_command_line_program.exe", @ScriptDir, @SW_HIDE)

Don't works: the command line program don't launch but with

$pid = run(a"_command_line_program.exe", @ScriptDir)
$Name_of_window = Pid_to_name_of_the_window($pid)
WinSetState($Name_of_window, "", @SW_HIDE)

This one works flawlessly but the window shows up about half second.

I think it's a bug, the app should run even with the @SW_HIDE flag.

And that's not a problem of mine since the second version works.

Please fix it and thanks for support.

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by jchd

Care to provide a real-world failing example?
Which error do you get?

comment:2 Changed 9 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

It's an application's choice whether it honors the show flag or not. Most applications do, some do not.

comment:3 Changed 9 years ago by Jpm

An example is SciTE editor which does not honor

comment:4 Changed 9 years ago by Le solutionneur

Additionals informations:

It should force the application to be hidden just like WinSetState (or a flag to decide to force it or no)

It's very annoying that many apps don't honor this and so we've to do the stuff I shown which make the window appear a few seconds.

Yet, it's an enhancement, not a bug anymore.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.