Modify

Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#2121 closed Bug (No Bug)

Au3Record creates incorrect function of WinWaitActivate

Reported by: guinness Owned by:
Milestone: Component: AutoIt
Version: 3.3.9.0 Severity: None
Keywords: Cc:

Description

Au3Record creates the function_WinWaitActivate instead of WinWaitActivate.

To reproduce the problem Start Au3Record >> Select 'Click To Record' (with default selected check-boxes >> Select a window >> Select 'Click To Stop' and you'll see the erroneous function.

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by Jpm

In fact to be able to generate the _Winwaitactive() UDF only once as you can incorporate several Au3Record session in the same script the UDF are not generate when launch under SciTE. You have a checkbox which allow to generate or not when launching Au3Record.
No bug.

comment:2 Changed 8 years ago by Jpm

  • Resolution set to No Bug
  • Status changed from new to closed

comment:3 Changed 8 years ago by Jpm

  • Resolution No Bug deleted
  • Status changed from closed to reopened

Thanks guiness to highlight that when launch directly without SciTE the option is not available.
So I reopen it to have a fix in this context

comment:4 Changed 8 years ago by Jpm

  • Resolution set to No Bug
  • Status changed from reopened to closed

In fact when saving the _WinWaitActive is created. The only error is related to ticket #2124 where an error is described for the call to Au3RecordSetup() that must be _Au3RecordSetup()
It is intended that the extra information does not appear in the log in case multiple recording is done.

comment:5 Changed 5 years ago by anonymous

Could you please look at this thread? There are multiple versions of the Au3Record and the one in the Extra folder that comes with AutoIt has this issue when run as a standalone app with no option to generate the UDFs. Also, this appears to be a new issue in 3.3 because I have an older version 3.1 and this does not happen with that one.
https://www.autoitscript.com/forum/topic/174316-au3record-generated-code-is-not-runnable/#comment-1261745

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.