Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2157 closed Bug (Fixed)

ProcessList() crashes on Windows Terminal Server Win2k8-R2

Reported by: HighGuy Owned by: Valik
Milestone: 3.3.9.5 Component: AutoIt
Version: 3.3.8.1 Severity: None
Keywords: Cc:

Description

Hi,

i have a script running on a Windows Terminal Server Win2k8-R2 that crashes completely in unknown circumstances from time to time. I was able to debug the crash to happen within the function ProcessList() and could reproduce it using the example script from the help file. I'm not sure if you will be able to reproduce it as well because it might occur only sometimes, but maybe you could find a problem analyzing the source code of this function. Please consider that this might only happen in multi-user environments.
By the way: I tried it with the latest beta release 3.3.9.2 and had no luck as well.

Thank you very much for analyzing this issue!

HighGuy

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by Valik

I can confirm a crash when the process count > 512. In a multi-user environment I can see that happening. Right now as a single user I have 70 processes and I just rebooted my system and haven't restarted everything. I will fix this bug since it is obvious. Can you check on your end if it's possible your system can hit > 512 processes? If so we can be reasonably certain that the crash is from that error.

comment:2 Changed 7 years ago by Valik

Note, 512 processes across all users is what I mean in case that wasn't clear.

comment:3 Changed 7 years ago by Valik

  • Milestone set to 3.3.9.5
  • Owner set to Valik
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed by revision [6974] in version: 3.3.9.5

comment:4 Changed 7 years ago by HighGuy

Hello Valik,

I can confirm your assumption. With about 20 users on our Terminal Server we have sometimes more or less than 512 processes running. This might explain why this behavior only occurs sometimes.

comment:5 Changed 7 years ago by Valik

That's exactly what I wanted to hear.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Valik.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.