Modify

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#2168 closed Bug (No Bug)

Updown control displayed on wrong TAB

Reported by: Emiel Wieldraaijer Owned by:
Milestone: Component: AutoIt
Version: 3.3.8.1 Severity: None
Keywords: GUICtrlCreateUpdown TAB Cc:

Description

Hi,

The Updown is displayed on the wrong tab at start, when you change the tabs and return back to the first tab the updown is not visible anymore.

This problem was reported before in a previous version and fixed.. as i remember correct before the introduction of the bugtrac

See the attached Picture for the exact problem

This problem can be solved by placing GUISetState() directly after GUICreate.. but this will mean that all GUI examples in the help need to be re-written

Best regards,

Emiel

; *** Start added by AutoIt3Wrapper ***
#include <WindowsConstants.au3>
; *** End added by AutoIt3Wrapper ***
#Region ;**** Directives created by AutoIt3Wrapper_GUI ****
#AutoIt3Wrapper_UseUpx=n
#AutoIt3Wrapper_Res_requestedExecutionLevel=asInvoker
#AutoIt3Wrapper_Add_Constants=n
#EndRegion ;**** Directives created by AutoIt3Wrapper_GUI ****
; *** Start added by AutoIt3Wrapper ***


#include <UpDownConstants.au3>
#include <GUIConstantsEx.au3>


$Parent = GuiCreate ("Test", 400, 400, -1, -1, BitOR($WS_SIZEBOX, $WS_SYSMENU, $WS_MINIMIZEBOX, $WS_MAXIMIZEBOX), $WS_EX_LAYOUTRTL)
$Parent = GuiCreate ("Test", 400, 400);, -1, -1, BitOR($WS_SIZEBOX, $WS_SYSMENU, $WS_MINIMIZEBOX, $WS_MAXIMIZEBOX), $WS_EX_LAYOUTRTL)
`
$filemenu = GUICtrlCreateMenu("&File")
$fileitem = GUICtrlCreateMenuItem("Open", $filemenu)
$Tab = GUICtrlCreateTab(10, 10, 380, 380)
$Tab1 = GUICtrlCreateTabItem("Tab1")
$Restart = GuictrlCreateButton("Restart", 200,100,150,20)
$Tab2 = GUICtrlCreateTabItem("Tab2")

$Port = GUICtrlCreateInput("21", 200, 200, 150, 20)
$PortUPDown = GUICtrlCreateUpdown($Port, BitOR($UDS_NOTHOUSANDS, $UDS_WRAP))

$Tab3 = GUICtrlCreateTabItem("Tab3")
GUISetState()

While 1
	$msg = GUIGetMsg()
	If $msg = $GUI_EVENT_CLOSE Then Exit
	If $msg = $Restart Then Run('"' & @AutoItExe & '"' & ' /AutoIt3ExecuteScript "' & @ScriptFullPath & '" /restart')
	If $msg = $fileitem Then  MsgBox(0, "Test", "Menu test")
WEnd

Attachments (1)

Updown.png (11.1 KB) - added by Emiel Wieldraaijer 7 years ago.
Problem displayed by image

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by Emiel Wieldraaijer

Problem displayed by image

comment:1 Changed 6 years ago by Jon

  • Resolution set to Rejected
  • Status changed from new to closed

comment:2 Changed 6 years ago by Jpm

  • Resolution Rejected deleted
  • Status changed from closed to reopened

Due to Menu creation.
Find the solution

comment:3 Changed 6 years ago by Emiel Wieldraaijer

Hi JPM,

This is not a bug

i forgot to close the TabItems with GUICtrlCreateTabItem("")

Sorry

Best regards,

Emiel Wieldraaijer

comment:4 Changed 6 years ago by Mat

  • Resolution set to No Bug
  • Status changed from reopened to closed

OP says no bug. Feel free to reopen jpm if you still feel this is a bug related to menu creation.

comment:5 Changed 6 years ago by Jpm

In fact the bug was still there but has been fixed with the 2167 solution
when not using the GUICtrlCreateTabItem("")

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.