Modify

Opened 7 years ago

Closed 7 years ago

#2187 closed Bug (Completed)

Unexpected Result in _GUICtrlRichEdit_Create

Reported by: tom_lyo@… Owned by: guinness
Milestone: 3.3.9.5 Component: Standard UDFs
Version: 3.3.8.0 Severity: None
Keywords: RichTextEdit Cc:

Description

In the _GUICtrlRichEdit_Create function, there is :
If Not _WinAPI_IsClassName($hWnd, $_GRE_sRTFClassName) Then Return SetError(1, 0, 0)

Mean : RichTextEdit can only be created in RichTextEdit window (i think this line must be deleted)
We actualy can make only one RichTextEdit because $_GRE_sRTFClassName is Set Inside _GUICtrlRichEdit_Create function, so if we call it a second time, RichTextEdit isn't created.

By the way (in the same function) :
If Not _ _GCR_IsNumeric($iLeft, ">=0") Then Return SetError(103, 0, 0)
If Not _ _GCR_IsNumeric($iTop, ">=0") Then Return SetError(104, 0, 0)

i think ">=0" must be deleted too
why force RichTextEdit to be on positive position ?

(I made a space between the too _ to avoid underline effect)

Attachments (1)

Exemple.au3 (885 bytes) - added by TommyDDR 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by TommyDDR

comment:1 follow-up: Changed 7 years ago by Jpm

The several richedit creation has been fix in the current beta.
for the other negative position it does not for me make sense to create someting outside the window. If really needed perhaps hiding the control is best instead of moving to a displaying area.
For me no BUG

comment:2 in reply to: ↑ 1 Changed 7 years ago by TommyDDR

Replying to Jpm:

The several richedit creation has been fix in the current beta.
for the other negative position it does not for me make sense to create someting outside the window. If really needed perhaps hiding the control is best instead of moving to a displaying area.
For me no BUG

I know it's not a bug but if the operating system allow us to do it.. why not just allow it for users, like GUICtrlCreateXXX ?
(By the way, _GUICtrlRichEdit_Create allow to create at position 5000. If negative positions are blocked, position beyond windows size need to be blocked too)

comment:3 Changed 7 years ago by AdmiralAlkex

The user should be free to create his controls anywhere he wants.
I don't know why we restrict it.

comment:4 Changed 7 years ago by guinness

  • Milestone set to 3.3.9.5
  • Owner set to guinness
  • Resolution set to Completed
  • Status changed from new to closed

Removed by revision [7232] in version: 3.3.9.5

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain guinness.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.