Modify

Opened 7 years ago

Closed 7 years ago

#2231 closed Bug (No Bug)

ControlSend case of text inconsistent

Reported by: multiades@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.8.1 Severity: None
Keywords: Cc:

Description

This was reported previously, but it was closed 2 years ago as "no bug". There definitely is a bug, and it's causing problems with a script. This code is used to enter a directory into an open dialog:

ControlSend("Import", "", "[CLASS:Edit; INSTANCE:1]", $directory)

the problem occurs when it is where it is supposed to enter:

"d:\directory\anotherdirectory\file.dat"

but instead enters:

"d;\directory\anotherdirectory\file.dat"

or

"d:|directory|anotherdirectory|file.dat"

The result is an invalid directory/file reference. Entry works correctly most of the time, but when it doesn't it causes a major error in the script. I have tried changing the key delay and keydown delay as follows, with no apparent improvement in accuracy:

AutoItSetOption ("sendkeydelay", 10)
AutoItSetOption ("sendkeydowndelay", 10)

Previous report was: http://www.autoitscript.com/trac/autoit/ticket/1535

I am not using a non-english keyboard layout, as was cited in the other bug report.

Thanks,
-Chris

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

You provided a script to reproduce the issue about as useful as the scripts 2 years ago. In other words, this is pointless. We can't reproduce it and the code looks fine on our end.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.