Modify

Opened 7 years ago

Closed 7 years ago

#2255 closed Bug (No Bug)

String value is treated as a number if starts with digits

Reported by: Vlad (bw0) Owned by:
Milestone: Component: AutoIt
Version: 3.3.8.1 Severity: None
Keywords: string as a number Cc:

Description

Hi,

I played with the code provided in the documentation and decided to do some tests. All of a sudden, when using a value like 20QAZ the script reports that this value is positive, though it is not a number. This can be checked with this short piece of code:

Local $var = "20QAZ"
If $var > 0 Then
MsgBox(4096, "", "Value is positive.")

I didn't find any mentioning about this. Could you please check if this is a bug?

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Try reading the guidelines next time. Specifically the one that says if you're asking a question you're in the wrong place.

Closing as no bug since, well, it's not a bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.