Modify

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#2312 closed Bug (Rejected)

Tray icon flashes into the black square

Reported by: go2008to@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.8.1 Severity: None
Keywords: tray, icon, flash Cc:

Description

Just in OS: Win 7 x64 Home Pro . Normal behaviour at WinXP.

#NoTrayIcon

Opt("TrayMenuMode", 1)
Local $exititem = TrayCreateItem("Exit")
TraySetState(5)

While 1
Local $msg = TrayGetMsg()
Select
     Case $msg = 0
         ContinueLoop
     Case $msg = $exititem
         ExitLoop
EndSelect
WEnd

Exit

http://www.autoitscript.com/forum/index.php

Attachments (5)

#2312 win8.1 jpm.png (5.4 KB) - added by Jpm 7 years ago.
tray.jpg (32.0 KB) - added by anonymous 7 years ago.
#2312 win8.1 jpm-1.png (74.7 KB) - added by Jpm 7 years ago.
Screenshot - jpm.png (120.4 KB) - added by Jpm 7 years ago.
Personalization.jpg (168.5 KB) - added by anonymous 7 years ago.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 8 years ago by trancexx

Is that for compiled script or not?

comment:2 Changed 8 years ago by Jpm

seems related with theme used.
I have no pb Under Win8 compiled or not

comment:3 Changed 8 years ago by go2008to@…

It is actual for x86 and x64 compiled (.exe) and native-script .au3 , there is no difference.
I use standard windows 7 Aero theme.

comment:4 Changed 7 years ago by Jon

  • Resolution set to Rejected
  • Status changed from new to closed

comment:5 Changed 7 years ago by anonymous

I have the same problem under Windows 8.1 (and also Windows 8).

Changed 7 years ago by Jpm

comment:6 Changed 7 years ago by Jpm

I don't have the same problem as I say see attach file
Just post a part of your screen so I can understand which specific theme you are using
Best for me is to understand your personalization.
I use the standard one

Changed 7 years ago by anonymous

comment:7 Changed 7 years ago by anonymous

No special desktop personalization and with this script:

TraySetIcon("%SystemRoot%\system32\SHELL32.dll", -100)
TraySetState(4)
While 1

Sleep(100)

WEnd

Changed 7 years ago by Jpm

comment:8 Changed 7 years ago by Jpm

I still have the good behavior see last attached file

comment:9 Changed 7 years ago by anonymous

That's interesting, I always had this issue with Windows 8 and 8.1! Any debug code you might want me to try on my machine?

Changed 7 years ago by Jpm

comment:10 Changed 7 years ago by Jpm

attach your personalization setting as he one I just attach

Changed 7 years ago by anonymous

comment:11 Changed 7 years ago by anonymous

I have attached it now.

comment:12 Changed 7 years ago by Jpm

Thanks
The bad news is I cannot reproduce it Under my clean install 8.1

comment:13 Changed 7 years ago by anonymous

OK, I just confirmed this: It is related to high DPI setting. At 100% it is fine. Try 125% and you will see it!

comment:14 Changed 7 years ago by Jpm

You get it it is due to this 125%.
Not sure AutoIt can do something for it

comment:15 Changed 7 years ago by anonymous

I think some of AutoIt functions are not DPI-aware, such as PixelGetColor(). See the discussion here: (http://www.autoitscript.com/forum/topic/156251-mouse-coordinates/)

comment:16 Changed 7 years ago by anonymous

Hello Jpm, The status of this bug still shows: "closed Bug (Rejected)". Now that the bug has been confirmed, are you going to re-open it? Thanks!

comment:17 Changed 7 years ago by Jpm

It is up to Jon to reopen.
For me I don't understand if it is not related with Windows itself I will not reopen it.

comment:18 Changed 7 years ago by anonymous

OK, let's hope DPI related issues will be sorted out soon.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.