Modify

Opened 7 years ago

Closed 6 years ago

#2317 closed Bug (Works For Me)

ObjCreate Memory Leak

Reported by: IanN1990 Owned by:
Milestone: Component: AutoIt
Version: 3.3.8.1 Severity: None
Keywords: Cc:

Description

According to the Helpfile. Setting any Object with a number or string is ment to release it from memory.

#NoTrayIcon

While 1
sleep(250)
Make()
WEnd

Func Make()
Local $o_object = ObjCreate("InternetExplorer.Application")
$o_object.quit
$o_object = "String"
EndFunc

As you can see by the code above, the Objcreate is called inside a function. The Object itself is set to a string. So the memory should be released.

Yet if you run the script, along side task-manager. You will see every time the function is called the memory for the autoit script goes up.

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by Jon

  • Resolution set to Rejected
  • Status changed from new to closed

comment:2 Changed 6 years ago by Jpm

  • Resolution Rejected deleted
  • Status changed from closed to reopened

The problem is still ther with the 3.3.9.19 so I reopen the ticket

Last edited 6 years ago by Jpm (previous) (diff)

comment:3 Changed 6 years ago by Jon

Seems to be an IE thing rather than an AutoIt thing. This script has constant memory use and it's doing a lot more COM interaction

While 1
sleep(100)
Make()
WEnd


Func Make()
; Counting the number of open shell windows

Local $oShell = ObjCreate("shell.application") ; Get the Windows Shell Object
Local $oShellWindows = $oShell.windows ; Get the collection of open shell Windows

If IsObj($oShellWindows) Then
    Local $sString = "" ; String for displaying purposes

    For $oWnd In $oShellWindows ; Count all existing shell windows
        $sString &= $oWnd.LocationName & @CRLF
    Next
EndIf

$oShell = "String"
EndFunc

comment:4 Changed 6 years ago by Jon

  • Resolution set to Works For Me
  • Status changed from reopened to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.