Modify

Opened 6 years ago

Closed 6 years ago

#2373 closed Bug (Fixed)

@ScriptDir returns trailing slash

Reported by: BinaryBrother@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.8.1 Severity: None
Keywords: Cc:

Description

@ScriptDir is returning a trailing slash for me, consistently, on the machine that I'm currently using.

The problem is either in functionality or documentation. The help documentation says that this Macro will NOT return a trailing slash.

Windows 7 x86
UAC Enabled
-All Stock

Relevant forum thread:
http://www.autoitscript.com/forum/topic/153104-scriptdir-returns-trailing-slash/

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by BinaryBrother@…

Only happens when the script is located in the root of a drive. Wraithdu and JLogan3o13 pointed this out. .

comment:2 Changed 6 years ago by guinness

This is intentional and was changed back in:

19th December, 2006 - v3.2.2.0
Fixed: @ScriptDir equal @WorkingDir for rootdir (x:\).

comment:3 Changed 6 years ago by anonymous

comment:4 Changed 6 years ago by Jpm

Definety we must update the doc for root because FileChangeDir(@ScriptDir) for a script located on root

comment:5 Changed 6 years ago by James

  • Resolution set to Fixed
  • Status changed from new to closed

I've updated this in the documentation. I don't know when it'll be included but it's done.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.