Modify

Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#240 closed Bug (Works For Me)

Add as Snippet

Reported by: Firestorm Owned by: Gary
Milestone: Component: SciTE4AutoIt
Version: Other Severity: None
Keywords: Cc:

Description

In SciTe, when you have selected text or nothing selected and right-click and click 'Add as Snippet', SciTe gives an error:

Error
_GUIImageList_AddIcon: -1

Attachments (1)

ERR.png (1.7 KB) - added by Zedna 12 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by TicketCleanup

  • Version set to Other

Automatic ticket cleanup.

comment:2 Changed 12 years ago by Gary

  • Owner changed from Jos to Gary
  • Status changed from new to assigned

comment:3 Changed 12 years ago by Gary

Works for me with no error.

What OS do you have?
What is the version of Snippet?

comment:4 Changed 12 years ago by Gary

If I had to guess it has to do with https://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2883648&SiteID=1

and running less than WinXP

Changed 12 years ago by Zedna

comment:5 Changed 12 years ago by Zedna

I can confirm this error on my WIN98SE.
See attached error screenshot.

comment:6 Changed 12 years ago by Firestorm

I'm on WINXP:SP2. Latest autoit version.

comment:7 Changed 12 years ago by Gary

  • Resolution set to Works For Me
  • Status changed from assigned to closed

I expect it to error in Win9x.

I can't duplicate the problem on WinXP Pro SP2 or SP3.

comment:8 Changed 10 years ago by Valik

I deleted an image from a user who thought it would be helpful to post a worthless image in a ticket that's over a year old. Really, you had to post an image of an error described in plain text in the description of the ticket?

comment:9 Changed 10 years ago by Zedna

@Valik

Sorry for iritating you Valik ;-|
I don't remeber this one but I think I wanted to show I can reproduce this error too.

I replied at the same year/month as original poster, not to already existing one year old ticket.

comment:10 Changed 10 years ago by Zedna

Now I tried the same and it works fine without any errors on my WinXP SP2 with AutoIt 3.2.12.1

comment:11 Changed 10 years ago by philip.hall@…

The attachment was not useless it demonstrates that the error message reported was exactly as quoted and not paraphrased, potentially missing out significant information.

I agree that this works fine on XP, but whatever the problem was it's back on Vista and 7, 64-bit versions at least. Pardon me for thinking this information might have been helpful.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Gary.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.