Modify

Opened 6 years ago

Closed 6 years ago

#2461 closed Bug (Fixed)

GUICtrlSetImage doesn't handle certain types of .gif file

Reported by: kev51773 Owned by: Jon
Milestone: 3.3.9.22 Component: AutoIt
Version: 3.3.8.1 Severity: None
Keywords: GUICtrlSetImage gif Cc:

Description

Using the attached files, try the following script.

GUICreate("test")
$pic = GUICtrlCreatePic("C:\blah\White.gif",0,0)
GUISetState()
sleep(1000)
GUICtrlSetImage($pic,"C:\blah\Blue.gif")
sleep(1000)
exit

A white image will be displayed, a second later it will be replaced by a blue image.

Now try the following (switching the order of the images)

GUICreate("test")
$pic = GUICtrlCreatePic("C:\blah\Blue.gif",0,0)
GUISetState()
sleep(1000)
GUICtrlSetImage($pic,"C:\blah\White.gif")
sleep(1000)
exit

A blue image will be displayed, the white image will never appear.

This doesn't happen with 8 bit gif images but seems to happen with anything less than 8 bit.
Also, it doesn't only happen with white, it happens with any colour where the values for R G & B are all greater than 0.

Attachments (2)

White.gif (62 bytes) - added by anonymous 6 years ago.
Blue.gif (62 bytes) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by anonymous

Changed 6 years ago by anonymous

comment:1 Changed 6 years ago by Jpm

The problem is not related with gif format but just a refresh problem

comment:2 Changed 6 years ago by Jon

  • Milestone set to 3.3.9.22
  • Owner set to Jon
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed by revision [9052] in version: 3.3.9.22

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.