Modify

Opened 7 years ago

Closed 6 years ago

#2545 closed Bug (No Bug)

HttpProxySet Return value

Reported by: Xenobiologist Owned by:
Milestone: Component: AutoIt
Version: 3.3.8.1 Severity: None
Keywords: HttpProxySet Cc:

Description

The helpfile says there is no return value.
Calling the function in a consolewrite always prints a 1 out.
FMPOV, either the documentation is wrong or the function.

So long,
Mega

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by Jpm

In Fact I don't think the doc is really wrong as AutoIt always return something but it this partivular case it is irrelevant.
If I remember well in another part of the doc by default for AutoIt builtin the default return is 1 as opposed to UDF return which is 0

comment:2 Changed 7 years ago by anonymous

It is not that important!
But if Autoit always returns something, then the doc should print out something like: Return value not analyzable or always 1 if it is really always 1. :-)

comment:3 Changed 6 years ago by Mat

  • Resolution set to No Bug
  • Status changed from new to closed

Closing this as not a bug. Saying the return value has no meaning, is the same as saying there is no meaningful return value, which is what the docs mean when they say "no return value".

There is always a return value, even if its just zero or "" or 1 in this case.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.