Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2590 closed Bug (No Bug)

@ProgramFilesDir results different for AutoIt 32bit and 64bit install.

Reported by: dogsurfer Owned by:
Milestone: Component: AutoIt
Version: 3.3.10.2 Severity: None
Keywords: @ProgramFilesDir Cc:

Description

Shouldn't @ProgramFilesDir give the same results for compatible or native install?

@ProgramFilesDir results
AutoIt 32bit install: C:\Program Files (x86)
AutoIt 64bit install: C:\Program Files

Test script on Win7sp1-64bit:

MsgBox(0, @AutoItX64, @ProgramFilesDir)

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by BrewManNH

The directory will change depending upon which version of the app you're running, either 64 bit or 32 bit. This has been discussed several times on the forums, and this type of question should have been posted there first. If you had, you would have realized that it's not a bug and that it's working exactly as it's supposed to.

BTW, it will also change the @SystemDir(system32 or SysWOW64) folder location depending upon the same criteria.

comment:2 Changed 6 years ago by guinness

  • Resolution set to No Bug
  • Status changed from new to closed

comment:3 Changed 6 years ago by dogsurfer

My thanks for the quick reply. My initial scan of the forums was not comprehensive enough. I see now this is also described in the help .chm file.

I see that Windows has a redirection mechanism returning entirely different values based on whether the 32 or 64 bit AutoIt program accesses it. So AutoIt returns that different value. But it breaks my scripts, and since it has been discussed several times in the forums, the way AutoIt implemented this is causing some of us to think it is a bug. I mean, same script, same system, but it is inconstant, unintuitive, and requires a code work-around to be compatible. It sure seems to quack like a bug.

Still, I can achieve the consistency I require by staying on the 32 bit version.

I truly appreciate AutoIt, and thank you for your support and time.

comment:4 Changed 6 years ago by guinness

Please re-direct any response to the Forum. Thank you.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.