Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2870 closed Bug (No Bug)

AutoIt send key combinations do not work sometimes

Reported by: icemang2@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.12.0 Severity: None
Keywords: Cc:

Description

When AutoIT is used to copy and paste several hundred lines of text from a text file, line by line (each line will be copied to clipboard using clipput() and inserted into an application using ctrl-v). Sometimes, v or v will be paste into the active window instead of the actual contents of the clipboard being dumped as is specified when send ("v")or ctrlsend is used.

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Jos

  • Resolution set to No Bug
  • Status changed from new to closed

.. and the bug is ..what?

Please refrain from creating BUG reports until you have some sort of confirmed BUG.
Visit our forum for questions/support.

Jos

comment:2 Changed 6 years ago by anonymous

Can you please expalin why this is not a bug?

If command send ("v) is used, the contents of the clipboard is supposed to be input into the field that has focus. However, when it is put in a loop which iterates over 400 lines (even with the sleep function before and after the send() function) , sometimes AUTOIT sends the raw text "v" and not the command CTRL-V to the text box. The result is that "v" and not the contents of the clipboard is paste to the save-as dialog box. So, my files are sometimes saved with file-name "V". As i said previously this happens off and on.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.