Modify

Opened 6 years ago

Closed 6 years ago

#2888 closed Bug (No Bug)

Error return code _WinAPI_DuplicateHandle

Reported by: step8876@… Owned by:
Milestone: Component: Standard UDFs
Version: 3.3.13.19 Severity: None
Keywords: Cc:

Description

(((

If @error Or Not $aResult[0] Then Return SetError(@error, @extended, 0)

)))
If $aResult[0] = 0 Then it returns 0 error
It should be something like this
(((

If @error Then Return SetError(@error, @extended, 0)
If Not $aResult[0] Then Return SetError(_WinAPI_GetLastError(),@extended,0)

)))

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Jpm

It is not a bug just read the doc which say on error 0 is return and if you want to know which kind of error it is the use responsability to call _WinAPI_GetLastError()

I understand it could have been done as you suggest but I was decided long time ago to return error like it is done right know

comment:2 Changed 6 years ago by guinness

  • Resolution set to No Bug
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.