Modify

Opened 6 years ago

Closed 6 years ago

#2905 closed Bug (Works For Me)

DirCopy Redirection Bug

Reported by: die-gabi-meier@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.10.2 Severity: None
Keywords: dir copy redirection Cc:

Description

1) manual create a folder tmp0 under /SysWOW64
2) put a test.txt into tmp0
3) DirCopy("C:\Windows\System32\tmp0", "C:\Windows\System32\tmp1")
4) script is compiled as x86

Expectation:
tmp0 with file is copyed and is placed under SysWOW64 as tmp1 (automatic redirection for x86 executables from System32 to SysWOW64)

Reality:
tmp1 is created under SysWOW64 WITHOUT txt file
AND tmp1 WITH txt file is created under System32

Testenvironment:
Windows 7 SP1 64Bit, German with AutoIt 3.3.10.2
(also tested with 3.3.12.0 and 3.3.13.19)

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Jpm

  • Resolution set to Works For Me
  • Status changed from new to closed

I assume you run your test in admin mode.
I try to reproduce Under Windows8.1 64_bit and it works as a charm

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.