Modify

Opened 12 years ago

Closed 12 years ago

#293 closed Bug (No Bug)

using CLASS and TEXT together...

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

there was fix in this issue with v3.2.10.0.
(Fixed: Control...() functions using CLASS and TEXT together sometimes incorrect.)

In my case there was no problems with v3.2.8.1, but when I update autoit to v3.2.12.0 today, several ControlClick() functions that using CLASS and TEXT together are not woking, so I had to remove all "TEXT:xxx" in my scripts.

Here is one of them not woking.

ControlClick($handle, "", "[CLASS:Button; TEXT:&Move; INSTANCE:10]")

thanks.

Attachments (0)

Change History (5)

comment:1 follow-up: Changed 12 years ago by Jon

That's because the bug caused instance to be ignored. In your example what you are actually asking AutoIt to look for is the 10th instance of a "Button" class with the text "&Move". I'm guessing you are not looking for the 10th instance. :)

comment:2 in reply to: ↑ 1 Changed 12 years ago by anonymous

Replying to Jon:

That's because the bug caused instance to be ignored. In your example what you are actually asking AutoIt to look for is the 10th instance of a "Button" class with the text "&Move". I'm guessing you are not looking for the 10th instance. :)

it's by Au3Info.

comment:3 follow-up: Changed 12 years ago by Jon

No, Au3info never shows an advanced description that uses those 3 together.

You either want "[CLASS:Button; INSTANCE:10]" or "[CLASS:Button; TEXT:&Move]".

comment:4 in reply to: ↑ 3 Changed 12 years ago by anonymous

Replying to Jon:

No, Au3info never shows an advanced description that uses those 3 together.

You either want "[CLASS:Button; INSTANCE:10]" or "[CLASS:Button; TEXT:&Move]".

Aren't you read help?

"e.g. Click the 2nd instance of a "Button" control containing the text "Finish"

ControlClick("My Window", "", "[CLASS:Button; TEXT:Finish; INSTANCE:2]")"
-from help file.

comment:5 Changed 12 years ago by Jon

  • Resolution set to No Bug
  • Severity set to None
  • Status changed from new to closed

I wrote the help.

You want the FIRST instance of a "Button" class containing the text "&Move". OR the 10th instance of a "Button" class.

Working as intended. No bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.